Airsoft Canada
BuyAirsoft

Go Back   Airsoft Canada > Discussion > Doctor's Corner
Home Forums Register Gallery FAQ Calendar
Retailers Community News/Info International Retailers IRC Today's Posts

G&G Arp9 - Mosfet LED flashing red on trigger pull. no response

:

Doctor's Corner

Reply
 
Thread Tools
Old February 20th, 2019, 18:42   #1
Quake
 
Join Date: Sep 2018
Location: East Coast
G&G Arp9 - Mosfet LED flashing red on trigger pull. no response

hello all,

I bought an G&G Arp9 that just arrived today. I had it switched to a deans connector and it looks like a solid job. I put a 11.1v LiPo battery into it and fired it for a few minutes with no issues. Then suddenly on a trigger pull I got no response.

I took the battery and mosfet out and say that when I pull the trigger that the LED on the mosfet is flashing red with each pull.

The battery wasn't fully charged so I thought maybe it was low and have charged it to full and still have the same response. I have tried 3 other batteries that work fine in another gun I have but no response on this except for the red led.

any ideas on what the issue might be and how to address it is appreciated it. since it has been switched to deans I don't know if G&G will warranty it and I assume they won't.
Quake is offline   Reply With Quote
Old February 20th, 2019, 23:16   #2
ThunderCactus
Not Eye Safe, Pretty Boy Maximus on the field take his picture!
 
ThunderCactus's Avatar
 
Join Date: Feb 2007
check to see if the motor connectors are still on?
ThunderCactus is offline   Reply With Quote
ReplyTop


Go Back   Airsoft Canada > Discussion > Doctor's Corner

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Airsoft Canada
BuyAirsoft

All times are GMT -4. The time now is 08:16.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.