Airsoft Canada
https://www.replicaairguns.ca/airsoft

Go Back   Airsoft Canada > Discussion > Accessories Discussion
Home Forums Register Gallery FAQ Calendar
Retailers Community News/Info International Retailers IRC Today's Posts

RS eotech problems

:

Accessories Discussion

Reply
 
Thread Tools
Old February 12th, 2012, 23:31   #1
swatt13
Captain Awesome
 
swatt13's Avatar
 
Join Date: May 2005
Location: Greater Grande Prairie (greater than vancouver)
RS eotech problems

My eotech has seemed to develop an issue. Won't turn on now. I did a bit of research and came up with pretty much nothing other than it is not all that uncommon. The only remedy was "send it back to eotech for repair and upgrades" I'm being told that could be 6 months.

Has anyone else had this issue and know the remedy?
Also what "upgrades" does eotech offer for a 552?
__________________
Age verifier southern Alberta

Quote:
Originally Posted by TokyoSeven
a Systema PTW is like KD, where the noodles are plated in gold and the cheese sauce is actually a pool of hot naked women.
swatt13 is offline   Reply With Quote
Old February 12th, 2012, 23:48   #2
kullwarrior
 
kullwarrior's Avatar
 
Join Date: Jan 2008
Location: Edmonton, AB, Canada
battery? battery contact?

I hate to say it but this is why you choose Aimpoint, if it breaks send it to sweden to avoid ITAR.
__________________
kullwarrior is offline   Reply With Quote
Old February 13th, 2012, 00:59   #3
swatt13
Captain Awesome
 
swatt13's Avatar
 
Join Date: May 2005
Location: Greater Grande Prairie (greater than vancouver)
checked it with a volt meter, reads good. its in the brain somewhere
__________________
Age verifier southern Alberta

Quote:
Originally Posted by TokyoSeven
a Systema PTW is like KD, where the noodles are plated in gold and the cheese sauce is actually a pool of hot naked women.
swatt13 is offline   Reply With Quote
Old February 13th, 2012, 01:12   #4
T_A_N_K
 
T_A_N_K's Avatar
 
Join Date: Sep 2006
Well if you try a DIY fix it may void warranty. Only other option, if you bought it from a retailer, ask him to return it, perhaps it may expedite the process.
T_A_N_K is offline   Reply With Quote
Old February 13th, 2012, 01:28   #5
viking9934
 
viking9934's Avatar
 
Join Date: Dec 2005
Location: Longueuil
What is your model of eotech? some if you turn on the NV models with the left button they power up in NV mode.

What type of batteries are you using? Should only use energizer lithium or equivalent.

have you lost the little battery rubber buffers and springs?

I had once the same problem than you and it was a batteries issue, the little thing had special taste for batteries...

Also do you have the old or new style buttons? because old style button
have issue, like condensation and moisture trouble. with my 552 i had problem during winter and in raining condition.

And last thing have you cleaned your contact? you wont see it , oxidation is unnoticeable to the naked eye. Use alcohol and Q-tips or the Eraser trick(just take an eraser and rub the surface of the contact. I have used it a lot of time in the army on radio)

good luck
__________________
Semper Fidelis
viking9934 is offline   Reply With Quote
Old February 13th, 2012, 01:47   #6
swatt13
Captain Awesome
 
swatt13's Avatar
 
Join Date: May 2005
Location: Greater Grande Prairie (greater than vancouver)
so far have tried them all, except the lithium batteries, but when you had the condensation problem, how did you rectify that?
__________________
Age verifier southern Alberta

Quote:
Originally Posted by TokyoSeven
a Systema PTW is like KD, where the noodles are plated in gold and the cheese sauce is actually a pool of hot naked women.
swatt13 is offline   Reply With Quote
Old February 13th, 2012, 07:25   #7
Tankdude
 
Join Date: Jan 2005
Location: East Coast, New Brunswick
I had the same thing happen to mine. You need a new battery housing as the contacts are either missing or broken. Check inside with a light and see if both contacts are still there.
Tankdude is offline   Reply With Quote
Old February 13th, 2012, 11:36   #8
viking9934
 
viking9934's Avatar
 
Join Date: Dec 2005
Location: Longueuil
Quote:
Originally Posted by swatt13 View Post
so far have tried them all, except the lithium batteries, but when you had the condensation problem, how did you rectify that?
When condensation start i let it dry inside without the batteries inside for 48 hours.

And after all this i bought a xps-3 and it have worked so far.( But i always will thrust my aimpoint more)
__________________
Semper Fidelis
viking9934 is offline   Reply With Quote
Old February 13th, 2012, 12:21   #9
swatt13
Captain Awesome
 
swatt13's Avatar
 
Join Date: May 2005
Location: Greater Grande Prairie (greater than vancouver)
It should t be the battery housing. I checked it with a volt meter and it's reading a complete circuit with the batteries installed. It has to be from the body contacts back.
__________________
Age verifier southern Alberta

Quote:
Originally Posted by TokyoSeven
a Systema PTW is like KD, where the noodles are plated in gold and the cheese sauce is actually a pool of hot naked women.
swatt13 is offline   Reply With Quote
Old February 13th, 2012, 12:45   #10
Danke
 
Danke's Avatar
 
Join Date: Oct 2007
Location: Danger Zone
Check the contacts on the body for corrosion. They're spring loaded so they should pop up and down. I had to give mine an aggressive clean with a plastic dremel brush. Mine was used and a bit abused. Now I keep a dab of grease on them to prevent corrosion and encourage the contacts not to get stuck down.

Now this part is tricky but you can grab a couple AAAs and leave the battery cap off. Line them up and connect the ends with something to complete the circuit and see if you can switch on.
__________________
Airsoft, where nothing is hurt but feelings.
Danke is offline   Reply With Quote
Old February 13th, 2012, 15:14   #11
5.56
 
5.56's Avatar
 
Join Date: May 2007
Location: Burnaby
If you have used it on real steel, I have read in CGN forums that these have a nack of failing after enduring recoil, which doesn't make much sense as they're meant to endure it.
Hope you get it sorted out, Brother. I have a RS EOTECH, too, and it would be a bitch to worry about sending it back for repair and risk getting it being screened by customs for ITAR on it's way back.
5.56 is offline   Reply With Quote
Old February 13th, 2012, 15:38   #12
Crunchmeister
 
Crunchmeister's Avatar
 
Join Date: Nov 2007
Location: In your bedroom going though your underwear drawer
I have a RS EOTech 552. I tried to get a new battery housing. Contacted EOTech about it, and they can't even ship parts to Canada because of ITAR restrictions. Ugh. Pain in the ass.
__________________
Crunchmeister is offline   Reply With Quote
Old February 13th, 2012, 16:06   #13
Danke
 
Danke's Avatar
 
Join Date: Oct 2007
Location: Danger Zone
Recoil kills the battery connections. On the older models the batteries are in line with the recoil so as the weapon jars back and forth they hammer the contacts.

Contrast that to the newest version with the battery compartment 90 to the axis of the bore.
__________________
Airsoft, where nothing is hurt but feelings.
Danke is offline   Reply With Quote
ReplyTop


Go Back   Airsoft Canada > Discussion > Accessories Discussion

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Airsoft Canada
https://www.replicaairguns.ca/airsoft

All times are GMT -4. The time now is 01:34.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.