Airsoft Canada
MILSIG

Go Back   Airsoft Canada > Discussion > Doctor's Corner > Gas Gun Solutions
Home Forums Register Gallery FAQ Calendar
Retailers Community News/Info International Retailers IRC Today's Posts

ksc glock 19 firing full auto *solved*

:

Gas Gun Solutions

Reply
 
Thread Tools
Old April 7th, 2006, 20:16   #1
Tex
 
Tex's Avatar
 
Join Date: Feb 2003
Location: Abbotsford, B.C.
ksc glock 19 firing full auto *solved*

Hi guys my good ol (used to be) trusty glock 19 has started to act funny. first I will tell you what it has upgraded and how old ect. ect. I bought this one about 2 years ago it is used and used alot, it has a metal slide & barrel, upgraded hammer spring, recoil guide rod and spring, inhanced floating vavle spring and in 2 mags I have high flows in one I have a stock valve.

In short I have a gas powered springer or ful auto for a full mag

In long, I was using green gas 2 months ago and it and all my gbb's worked fine but 2 months ago I ran out of green and thought id buy an AI adapter so I put the guns in their case the 3 mags for the 19 had a small amount of gas left in them, so now I have propane filled up first shot everything seems fine pull trigger again and nothing, removed mag and checked out the hammer and it was not cocked now the slide did cycle fully, tested a few more time to make sure it was getting full recoil and it is. Then I found out if i hold the trigger down its full auto but as soon as I stop I have to rack the slide again. looking inside there is some wear on some parts but its not as bad as my other glocks wich are working fine still, also floating/rocket valve and all other parts are not broken.

could it be the floating valve spring this is the only gun I own with that spring and it is the only one not working, would stronger or weaker be better?

anyone else have anything like this

thanks for reading and thanks for any help
Tex is offline   Reply With Quote
Old April 7th, 2006, 20:43   #2
CDN_Stalker
Official ASC Bladesmith
 
CDN_Stalker's Avatar
 
Join Date: Jul 2003
Location: Ottawa, Ont.
Send a message via MSN to CDN_Stalker
Maybe the hammer catch sear has broken? If the catch can't stop the hammer after each shot, it'll fire in full. Check inside to see if any broken parts.
CDN_Stalker is offline   Reply With Quote
Old April 7th, 2006, 20:50   #3
Tex
 
Tex's Avatar
 
Join Date: Feb 2003
Location: Abbotsford, B.C.
Thanks CDN_Stalker, no parts broken or missing, after posting I tryed my glock 17 hammer parts in the 19 and the same problem exist so I am thinking floating valve or.... well I am out of ors. but now because I try to be a glass half full kinda guy I will look at like a free upgrade to a 23f :-D but still want to fix it .
Tex is offline   Reply With Quote
Old April 7th, 2006, 21:03   #4
mirage13
 
Join Date: Mar 2005
Location: Toronto
A while ago I wrote an short article about converting my TM Glock 26 to full auto...

http://www.airsoftcanada.com/showthr...ull+auto+glock

While the apparent outcome is that it doesn't work on Marui's Glock, the concept, I believe, is rather the same. (That is, if KSC's semi-auto Glocks have the same internal system as TM's 26).

Anyways, hope this helps in some way.
mirage13 is offline   Reply With Quote
Old April 7th, 2006, 21:05   #5
CDN_Stalker
Official ASC Bladesmith
 
CDN_Stalker's Avatar
 
Join Date: Jul 2003
Location: Ottawa, Ont.
Send a message via MSN to CDN_Stalker
Quote:
Originally Posted by Tex
Thanks CDN_Stalker, no parts broken or missing, after posting I tryed my glock 17 hammer parts in the 19 and the same problem exist so I am thinking floating valve or.... well I am out of ors. but now because I try to be a glass half full kinda guy I will look at like a free upgrade to a 23f :-D but still want to fix it .
Good luck!
CDN_Stalker is offline   Reply With Quote
Old April 7th, 2006, 22:56   #6
JohnnyDo
 
JohnnyDo's Avatar
 
Join Date: Apr 2005
Location: Calgary, AB
Send a message via MSN to JohnnyDo
it's probably the trigger bar. Since you've taken the lower half of the gun apart, this shodul be pretty easy for you to do.

you need to bend the rear section of the trigger bar downwards slightly. To find out how much remove the slide then press the trigger just slightly as to not fire the hammer. push the nib on top of the trigger bar that is beside the hammer down. this will dis-engauge the trigger from the hammer. the distance this nib has to move for the gun to fire semi auto is very little. if the nib or the slide is worn then the nib won't press down and the sear will not lock onto the hammer when you pull the trigger so you'll get full auto.

the trick is to bend the trigger bar just after the bend where the large square outline goes beside the hammer. bend the trigger bar with pliers *slightly* downwards such that the nib on the back of the large square of the bar is pointing downward. remember the word *slightly* means exactly that .. its a very very small ammount, too much and the gun won't work, too little and your still left with full auto. I'd have to say you need to use "finger tight" presure when you bend with pliers to give you an idea of how much force is required.

to test .. pull back the hammer, pull the trigger a bit and push down on teh trigger bar .. idealy you would want the bar to release the sear that holds he hammer so that the hammer stays in place with the trigger bar being moved downward about 0.5 - 1mm *very little effort*

hope this helps.
JohnnyDo is offline   Reply With Quote
Old April 8th, 2006, 18:40   #7
Tex
 
Tex's Avatar
 
Join Date: Feb 2003
Location: Abbotsford, B.C.
Thanks for the help guys, This one had me scratching my head for a while but it turns out It was my hop up rubber, it got damaged some how and the nozzle for the blowback chamber was sticking to it causing the slide not to return all the way foward and not releasing part #81 so part #78 was holding the valve open. New hopup rubber intalled and it's as good as new.

JohnnyDo, thanks trigger bar was one of my first thoughts too I have had that happen to one of my other older glocks. but not this time.
Tex is offline   Reply With Quote
Old January 12th, 2008, 01:37   #8
airborneboi69
 
airborneboi69's Avatar
 
Join Date: Sep 2007
Location: Pembroke on
Send a message via MSN to airborneboi69
could you get me a hopup rubber my g18c did the same as a result the wepon doesnt cycle right and leaks,full auto doesnt work eitherused to fire a burts then you needed to re rack the gun to continue.......?
__________________
airborneboi69
airborneboi69 is offline   Reply With Quote
ReplyTop


Go Back   Airsoft Canada > Discussion > Doctor's Corner > Gas Gun Solutions

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Airsoft Canada
MILSIG

All times are GMT -4. The time now is 21:33.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.