Airsoft Canada

Go Back   Airsoft Canada > Information Center > Newbie Tank
Home Forums Register Gallery FAQ Calendar
Retailers Community News/Info International Retailers IRC Today's Posts

Hi-Cap Problems


Newbie Tank

Thread Tools Search this Thread
Old April 20th, 2011, 08:32   #1
Shinka Prime
Shinka Prime's Avatar
Join Date: Mar 2009
Location: Kentville, Nova Scotia, Canada
Hi-Cap Problems

Hey folks! I have an M4A17 AEG with a hi-cap mag. I'm having a problem with overfeeding. When I fire in semi mode, I get three shots before I have to remove the clip and empty out the reciever. I'm not even going to start on full auto ~shudders~

What I'm wondering is, can this be resolved by adjusting my hop-up? Am I winding the clip too much? I haven't had any issues with previous mid-cap mags. Maybe I'm just not used to the clips? Any advice would be greatly appreciated!

Last edited by Shinka Prime; April 20th, 2011 at 08:32.. Reason: removed unnecessary line.
Shinka Prime is offline   Reply With Quote
Old April 20th, 2011, 12:28   #2
Strelok's Avatar
Join Date: Jun 2006
Location: Brandon Manitoba
M4A17? What brand is this? If its the clear M4 from walmart the gun alone is a serious problem.

What happens exactly after three shots? Does it jam? Or does it stop feeding? Highcap magazines are crappy to begin with so its prolly best if you just stick to your midcaps.
Strelok is offline   Reply With Quote

Go Back   Airsoft Canada > Information Center > Newbie Tank


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Airsoft Canada

All times are GMT -4. The time now is 01:15.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2016, vBulletin Solutions, Inc.