Airsoft Canada
Airsoft Depot

Go Back   Airsoft Canada > Discussion > Doctor's Corner
Home Forums Register Gallery FAQ Calendar
Retailers Community News/Info International Retailers IRC Today's Posts

WE Scar with RA Tech trigger assembly only half cocking.

:

Doctor's Corner

Reply
 
Thread Tools
Old April 20th, 2012, 17:45   #1
O.S.O.K
 
Join Date: Aug 2009
Location: Durham Region, Ontario
WE Scar with RA Tech trigger assembly only half cocking.

I've got an open boot scar that I'm having loads of issues with but at this point I think I'm down to the last two. One, I need a new piston but primarily I need the long piston return spring but can't seem to find them anywhere online, any ideas? Two, when you pull back the charging hand all the way the hammer only cocks halfway unless you absolutely rip on it harder than it would recoil, even with the mag seated as fully as it can be. I've got all the RA tech parts in it and it's all seen very minimal wear so it's not trigger parts wear down or at least shouldn't be. Any ideas as to the cause of this and possible solutions?
__________________
-SGM.
"How do you know what kind of god damn day it is?"
"What are you a fuckin' weather man now?"
"If any of you sons of bitches call me grandpa, I'll kill you"
O.S.O.K is offline   Reply With Quote
Old April 21st, 2012, 16:37   #2
Ross
 
Ross's Avatar
 
Join Date: Nov 2009
Location: Winnipeg
if you put the oem parts back in, does this problem still exist? the ratech upgrade trigger group was designed for the we m4 and has slight compatibility issues with the scar. The trigger being the wrong size and i think a few dimensions of the trigger group need to be open bolt specific for it to work properly.
__________________
Ross is offline   Reply With Quote
Old April 24th, 2012, 01:58   #3
O.S.O.K
 
Join Date: Aug 2009
Location: Durham Region, Ontario
I've put all the stock open bolt trigger parts back in and it seems they work fine still not firing correctly though but that seems to be more of a gas delivery issue at this point, be it either due to mags not seating fully up into the mag well or because the nozzle has seen its final days. Need a new nozzle for sure regardless as the rear O-ring is completely gone. Oh and one other thing that might be contributing to the issue, while using the RA tech steel bolt lower on the steel or even the stock upper the bolt will not go completely forward, it stays roughly 3/4 of a centimeter back.

Upon inspection the RA tech lower is noticeably different from the stock but I've yet to confirm the point of friction or meeting it two parts that is causing this.

I'm about at the end of my rope trying to get this thing working myself so I'm just going to take it in and let them deal with it, $60 is worth less than all the time I've spent on it thus far.

And if that and the fact that my other rifle isn't firing (cheap stock Chinese parts to be replaced soon) went to fire my KWA 1911 ptp earlier this evening and the god damn cylinder snapped in half.... It fired less than 200 rounds, properly maintained never dropped and it was a dry fire... Must have just been a faulty casting.

Thanks for the info.
__________________
-SGM.
"How do you know what kind of god damn day it is?"
"What are you a fuckin' weather man now?"
"If any of you sons of bitches call me grandpa, I'll kill you"
O.S.O.K is offline   Reply With Quote
ReplyTop


Go Back   Airsoft Canada > Discussion > Doctor's Corner

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Airsoft Canada
Airsoft Depot

All times are GMT -4. The time now is 05:40.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.