View Single Post
Old January 8th, 2010, 07:20   #1
Slow mo.
Slono's Avatar
Join Date: Aug 2009
Location: GTA
Sticky / Stuck Slide?

I put together this Kimber Warrior with a metal Nova kit and all seemed fine until I started shooting it. First the trigger didn't work about 20% of the time, and when I thought I fixed that another problem arose. Once the trigger is pulled, the slide proceeds with its normal functions. I know it blows back because I can feel it kick, but what I don't know is how it gets stuck in the position you see in the pictures. It feels like the tolerance is too tight between the slide and its rails and I have to use strength to unstick it before manually racking it and sling shotting it back to battery. This happens very often. It has been lubed and racked a million times so I don't know what's wrong.

Internal upgrades:
- Recoil and Hammer springs
- KM High Flow Valve
- Tanio Koba Twist Inner Barrel
- Firefly Hop up rubber

I do not know if any of these upgrades can be a factor in the aforementioned problem, but I listed them to let you know what I have replaced in the gun. Has anybody else had this problem before with their guns? Does anybody have a solution? Or perhaps a diagnosis? Any help is HUGELY appreciated. I just finished building this baby and want to shoot her without something going wrong.

The ultimate measure of a man is not where he stands
in moments of comfort and convenience, but where he
stands at times of challenge and controversy.
- Martin Luther King, Jr.

Last edited by Slono; January 8th, 2010 at 07:23..
Slono is offline   Reply With Quote